使用PHP 5.4版本时要注意的地方

特别注意:

使用PHP 5.4 时,不要在函数内嵌套使用函数,否则可能会报500错误!

惨痛经历:

在CI(CodeIgniter, http://codeigniter.org.cn)框架下,某控制器中写以下代码时会报500错误:

而以下代码则正常:

【参考:使用PHP5.4遇到的其他问题】

1.php5.4后htmlspecialchars输出为空的问题

发表评论