wordpress——Unable to locate WordPress root directory

升级wordpress时,可能会遇到如下提示:

解决方法:

编辑wordpress项目根目录下的wp-config.php文件,在末尾加上如下代码:

 

平滑升级Nginx

当Nginx服务升级到新的版本时,必须要将旧的二进制文件Nginx替换掉,通常情况下这是需要重启服务的,但Nginx支持不重启服务来完成新版本的平滑升级。

平滑升级步骤:

1.通知正在运行的旧版本Nginx准备升级。通过向master进程发送URL2信号可达到目的:

这时,运行中的Nginx会将pid文件重命名,如将/usr/local/nginx/logs/nginx.pid重命名为/usr/local/nginx/logs/nginx.pid.oldbin,这样新的Nginx才有可能启动成功。

2.启动新版本的Nginx,这时通过ps命令可以发现新旧版本的Nginx在同时运行。

3.通过kill命令向旧版本的master进程发送SIGQUIT信号,以“优雅”的方式关闭旧版本的Nginx。随后将只有新版本的Nginx服务运行,此时平滑升级完毕。

【摘自:《深入理解Nginx:模块开发与架构解析(第2版)》 陶辉 著】

 

centos安装python2.7

原标题:「centos6默认python2.6升级2.7」

本文介绍CentOS 6.3从自带的Pyhon版本是2.6升级到2.7.6的方法。

因为CentOS系统中旧版本的Python已被深度依赖,所以不能卸载原有的Python,只能全新安装。

1.下载Pyhon,选择下载Gzipped source tar ball (2.7.6) (sig)

网址https://www.python.org/download/releases/2.7.6

2.解压安装,命令如下

tar -xvf Python-2.7.6.tgz

cd Python-2.7.6

./configure –prefix=/usr/local/python2.7

make

make install

3.创建链接来使系统默认python变为python2.7

ln -fs /usr/local/python2.7/bin/python2.7 /usr/bin/python

4.查看Python版本

python –V

5.修改yum配置(否则yum无法正常运行)

vi /usr/bin/yum

将第一行的#!/usr/bin/python修改为系统原有的python版本地址#!/usr/bin/python2.6

 

至此CentOS6.3系统Python已成功升级至2.7.6版本。

【摘自:http://www.centoscn.com/image-text/config/2015/0325/5005.html】