安装swoole

若使用pecl或编译安装swoole时,出现如下类似错误,

则需要升级下gcc(达到5.0以上版本):

【摘自:】https://forum.phalconphp.com/discussion/17595/problem-with-compiled-phal …

安装swoole时可能出现的错误

错误内容类似如下:

解决方式:

【摘自:】https://github.com/swoole/swoole-src/issues/2119 PS, 用 pecl install swoole 时,使用默认安装配置项比较容易成功